Sign in to follow this  
moosedawg

Tractors are underpowered

Recommended Posts

So far, all the tractors in game seem extremely underpowered.  I took my Zetor Forterra 150 HD to Columbia while playing the My First Farm scenario and by itself, unloaded, not pulling anything, it can barely go up the hill to the first shed where I'm supposed to pick up the cistern!  I would think a tractor rated as a heavy tractor with 147 HP would be able to climb a small hill when it's not pulling anything. I could understand it having trouble if it were pulling a heavy trailer, but by itself? The Landini Rex couldn't even make it at all. It stalled out half way up, I had to drive switchbacks to get it up there. I know it's a tiny tractor, but again, I wasn't pulling anything. I should at least be able to drive ANY unladen tractor up a small incline to get to the blasted shed!  I have the same issue in the Montana map too.  Even the slightest incline and your tractor barely makes it. I keep wanting an option to pop it into low gear to get up the dang hill!

Share this post


Link to post
Share on other sites

I've noticed this, too, when I transfer my vehicles from one map to the other. It's a bug. I was going to report it today.

But fortunately I found a simple workaround. Just save when you get to the new map and reload that same save right after. The tractor will be fine afterwards.

When you go back to another map, do the same procedure. It's a minor annoyance, but at least not a game-breaking bug.

Share this post


Link to post
Share on other sites
14 hours ago, Gabrielmpf said:

I've noticed this, too, when I transfer my vehicles from one map to the other. It's a bug. I was going to report it today.

But fortunately I found a simple workaround. Just save when you get to the new map and reload that same save right after. The tractor will be fine afterwards.

When you go back to another map, do the same procedure. It's a minor annoyance, but at least not a game-breaking bug.

Thanks SO much for that information! I shall try that this evening.

Share this post


Link to post
Share on other sites
On April 2, 2018 at 11:34 AM, Gabrielmpf said:

I've noticed this, too, when I transfer my vehicles from one map to the other. It's a bug. I was going to report it today.

But fortunately I found a simple workaround. Just save when you get to the new map and reload that same save right after. The tractor will be fine afterwards.

When you go back to another map, do the same procedure. It's a minor annoyance, but at least not a game-breaking bug.

Same thing here,at first i thought my tractor was damaged and needed repaired but it still persisted after maintenance,once i reloaded the save all was fine.

The same thing happens with workers,they will randomly go on strike and refuse to work a field,saving the game then reloading fixes it and they will work fields again.

Couple of strange bugs,particularly the tractors hp suddenly dropping,its almost as if the tractor is clipping into the ground causing it to drag on the ground thus making the tractor struggle.

Share this post


Link to post
Share on other sites

Agreed, the JCB, which sports that fastest speeds I know of to date, will run 42mph.  If I hook an empty trailer to it, it slows to 14mph and when I load the trailer, it gets even slower.  Relogging has not made a difference.  This is the JCB 4220 with the Akpril Masse C-1500 counterweight and the Wielton PRC-2B/W 10 Ton trailer.  With this configuration empty it still should achieve 42mph, it just make take it a bit longer to wind up, Even full it should achieve the same speed, but take longer to wind up and longer to stop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this