Modding issues - Default_Levels

Recommended Posts

Hey everybody,

i've been trying to get rid of weapon durability for a while now 
by editing the default_levels, but no matter what i do the game simply
won't accept the changes and somehow reverts back to the normal settings somehow.
I tried putting the file in Data0.pak and Data3.pak, tried using the "out" folder
however i am not getting anywhere. (tried following all walkthroughs i could find)
Game works fine even if i completely
delete the default_levels, so i guess the data must be hidden somewhere else?

Any help would be appreciated since i'm completely out of ideas and 
so is google...

Share this post

Link to post
Share on other sites


use the data3.pak way .

You mean the default_levels.xml


I did not find the weapon duration variable



You can disable the repair weapon

in the inventory_gen.scr

or other inventory scripts, it depends

which weapon you want to edit.

Change this variable :


into false.

So the weapon will have infinite duration

but the damage will decrease slowly.

And you ´ll have to change this variable for

all weapons , one by one.


But maybe there ´s another way to change

this for any weapon.


And the default_levels may not be used

when the player have changed his level

or skills?

Share this post

Link to post
Share on other sites

Yes, i meant the default_levels.xml file.

I've successfully done this before with the Data0.pak since the changes made in the data3.pak
was ignored by the game for some reason(i checked that it wasn't a formatting issue)

Basically you just have to change 2 lines and weapon durability is disabled for all weapons.
Just search for "durability" and you'll find 3 lines, sounds something like: bluntweapondurability, sharpweapondurability and a chargedweapondurability.
(standard value is 0.1 i believe). Change their values to 0 and weapons won't suffer durability loss at all.

It's just that this time i can't get it working so there must have been some kind of update i can't around.  

Share this post

Link to post
Share on other sites

Found the solution - Seems there's been an update that reverts all changes to the game if you're online.
Simply changing the game mode to singleplayer is insufficient and i have to play the game with steam in offline mode instead

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now