Sign in to follow this  
ExtendedMagz

Developer Tools - Missing Walls, Doors, And Ai

Recommended Posts

So i was making a map, when i decided to create a new area. 

 

Suddenly, when playtesting, it started bugging out alot, and it started flashing the wall texture: (picture below)

http://imgur.com/c3mYd88

 

Then, after some more playtesting, whole walls were gone. It worked fine before, but this time, every wall was gone. 

http://imgur.com/FAmwsGH

 

In the editor, it looks completely fine:

http://imgur.com/cBaZKmR

 

And doors were missing, aswell as AI, and my playermodel! 

http://imgur.com/Dh4GPyV

http://imgur.com/jApzdin

 

Please help me, as i am very frustrated, and dont know what to do! 

Thanks in advance. 

Share this post


Link to post
Share on other sites

Try to share your map with someone that will test it on his pc then report if he have the same glitch.

 

If he does have the same issue, it means the map have some problem.

 

And if the map have no invisible walls on his pc, it means

You have something wrong with dying light or devtools install.

 

It seams this user have a similar problem:

http://steamcommunity.com/workshop/discussions/-1/357284767232252830/?appid=239140

 

And i saw other people complaining about the same issue

On both techland forum also in Dying light steam workshop

Discussions.

Edited by cr1m3

Share this post


Link to post
Share on other sites

Try to share your map with someone that will test it on his pc then report if he have the same glitch.

 

If he does have the same issue, it means the map have some problem.

 

And if the map have no invisible walls on his pc, it means

You have something wrong with dying light or devtools install.

 

It seams this user have a similar problem:

http://steamcommunity.com/workshop/discussions/-1/357284767232252830/?appid=239140

 

And i saw other people complaining about the same issue

On both techland forum also in Dying light steam workshop

Discussions.

Would re-install of Dying Light be ideal? I already re-installed dev tools, didnt work, unfortunately. 

Share this post


Link to post
Share on other sites

Would re-install of Dying Light be ideal? I already re-installed dev tools, didnt work, unfortunately.

Before to reinstall, check both game and devtools cache integrity by right click on them in steam to open their properties.

 

Then if you reinstall, yes, reinstall both game and tools cause the tools are tied to the game and use game assets and almost everything in game data.

 

I can ´t say if it will fix your problem but this is a good start.

 

Also try to make a new map and add the same walls to test .

 

If all is fine in the new map, the glitched map could be broken.

 

As i said above you can share your map on the workshop

Or on a sharing cloud or site.

I mean if someone can test on another pc.

Share this post


Link to post
Share on other sites

Before to reinstall, check both game and devtools cache integrity by right click on them in steam to open their properties.

 

Then if you reinstall, yes, reinstall both game and tools cause the tools are tied to the game and use game assets and almost everything in game data.

 

I can ´t say if it will fix your problem but this is a good start.

 

Also try to make a new map and add the same walls to test .

 

If all is fine in the new map, the glitched map could be broken.

 

As i said above you can share your map on the workshop

Or on a sharing cloud or site.

I mean if someone can test on another pc.

Nope, didnt work, this is what i am ending out with. 

 

http://imgur.com/TNihHom

 

The doors are missing, and AI is not visible either.. 

Share this post


Link to post
Share on other sites

BUMP

Please help!

Please share your map so that i or someone can test this.

 

You can share on the workshop then tell us the map name.

 

Or there ´s other sharing sites like zippyshare (no subscibe)

, mega (account needed), google drive and so on...

Share this post


Link to post
Share on other sites

Edit : I figured it out!

 

Next problem xD 

 

I recently got some sort of grid, when i want to move my objects, it snaps to the next grid line.. It looks like this

(I pressed 4, but i did the same with and without the snap tool) 

 

http://imgur.com/P19adEv


Please share your map so that i or someone can test this.

You can share on the workshop then tell us the map name.

Or there ´s other sharing sites like zippyshare (no subscibe)
, mega (account needed), google drive and so on...

 

 


Share this post


Link to post
Share on other sites

Edit : I figured it out!

 

 

How did you fixed the problem?

 

So that you can teach us how to fix this , i mean for all community in case of someone have the same issue.

 

Thanks in advance.

( i linked both topics about the same sort of issue:

http://steamcommunity.com/workshop/discussions/-1/357284767232252830/?appid=239140

)

 

Now for the grid:

 

http://steamcommunity.com/workshop/discussions/-1/594820656473297860/?appid=239140

Edited by cr1m3

Share this post


Link to post
Share on other sites

How did you fixed the problem?

 

So that you can teach us how to fix this , i mean for all community in case of someone have the same issue.

 

Thanks in advance.

( i linked both topics about the same sort of issue:

http://steamcommunity.com/workshop/discussions/-1/357284767232252830/?appid=239140

)

 

Now for the grid:

 

http://steamcommunity.com/workshop/discussions/-1/594820656473297860/?appid=239140

I went to the graphics tab in game, under cheat. Went to the very bottom, and toggled it on/off i dont remember. I must have left something running there..

 

Now, can you also tell me how to remove the hud, when ingame? I am making a horror map, so i want the hud completely gone. 

 

And also, how to remove the flashligt? 

Edited by ExtendedMagz

Share this post


Link to post
Share on other sites

I went to the graphics tab in game, under cheat. Went to the very bottom, and toggled it on/off i dont remember. I must have left something running there..

 

Now, can you also tell me how to remove the hud, when ingame? I am making a horror map, so i want the hud completely gone. 

 

And also, how to remove the flashligt? 

 

Thanks a lot ExtendedMags for your solution ;)

Share this post


Link to post
Share on other sites

How did you fixed the problem?

 

So that you can teach us how to fix this , i mean for all community in case of someone have the same issue.

 

Thanks in advance.

( i linked both topics about the same sort of issue:

http://steamcommunity.com/workshop/discussions/-1/357284767232252830/?appid=239140

)

 

Now for the grid:

 

http://steamcommunity.com/workshop/discussions/-1/594820656473297860/?appid=239140

Also, how do i make a actor? The only thing i see when i want the change a NPC's class to actor, is the tab "AI" please help

Share this post


Link to post
Share on other sites

I ´m not an admin , just a mapper like you.

 

But can you mark this topic as answered or solved in the topic options.

 

Then create a new topic to ask other questions.

For example the title could be " questions about ..."

So that you can group many questions inside.

 

I just ask this for making the forum easier to browse for users and find answers quickly.

 

As you can see you helped someone else by fixing the cheat options and i say thank you.

 

I ´ll try to answer some of your questions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this