Sign in to follow this  
Followers 0
Gabrielmpf

BUG - Italy - Long Time to Load

14 posts in this topic

UPDATE 2: The game doesn't even load completely when traveling to Italy (and Colombia) anymore. Just crashes. Have tried multiple times, but it just keeps crashing.

 

UPDATE: So, I decided to wait for the game to load in Italy, and it turns out it does load, but only after about 20 minutes. Colombia suffers from the same issue as well.

This is not ideal, of course, but if you have patience (which I'm sure you have lots, if you're still playing the game), you can get to Italy.

I also found out that this happens in Japan, too, although the loading times are about 5 minutes.

Yet another bug to crush, hopefully in the next update.

 

Hey guys,

So, I've come across another big bug in the game. This time, I can't go to Italy, as the game stays indefinitely in the loading screen.

I've already hard reset my console, reinstalled the game. Nothing works.

I had previously been farming in Montana, Japan, and Germany (in that order), and decided to expand my farm to Italy.

The first time, I got there without problems. Bought a couple of new devices (water cistern and sprayer). However, when I attempted to go there a second time to harvest my orchards, the game stays in the loading screen, right almost to the end, but never finishes loading.

This is getting so frustrating. After not being able to buy sheep in Germany, now I have an even bigger issue with the game, as now I can't actually travel to a location.

You guys now that I'm one of the best advocates of the game and have been having a great time, despite all its bugs and issues. But this is beyond frustrating. I want to continue playing, because I really like the game, but bug after bug, it's just getting so damn tiresome.

It seems as though the more you play the more likely the chances of getting a game-breaking bug.

I hope the much anticipated update fixes all these problems, because right now, the game is so unstable, you don't know when the next issue is going to appear.

Edited by Gabrielmpf

Share this post


Link to post
Share on other sites
7 minutes ago, Irish farmer said:

Having the same problem myself, I have reported it the support team, they have passed it on to the the developers so hopefully they can get it fixed

Do you happen to have any DLC vehicles on that map? Besides the two freebies JCB and Mitsubishi pickup?

Because I bought the small Landini tractor that was available in the store, and used it for my orchards in Italy.

I'm thinking this might be causing the issue but I'm not sure. I tested it with a new save starting in Italy, without the Landini DLC, and the game does load without any problems.

I don't have any other DLC vehicles, but wouldn't be surprised it this happened with them. It's like these DLCs are not correctly implemented into the game.

Share this post


Link to post
Share on other sites
7 hours ago, Mr Squealypig said:

I have all the DLC vehicles and have not had this issue yet, but I will check again in a little while.

Have you traveled to all countries in Free Farming mode? Do you have any of the DLC vehicles in those maps, or do you travel with them back and forth to Montana?

If you try this, be sure to have multiple save slots, just to be safe.

Share this post


Link to post
Share on other sites
20 hours ago, Gabrielmpf said:

Have you traveled to all countries in Free Farming mode? Do you have any of the DLC vehicles in those maps, or do you travel with them back and forth to Montana?

If you try this, be sure to have multiple save slots, just to be safe.

I have the Landini and Lindner tractors and the mower on Montana and another Lindner tractor on Italy.

Share this post


Link to post
Share on other sites

Guess it could be random, then. Which is even worse, because it can happen any time, and it would be difficult to pinpoint the cause.

Share this post


Link to post
Share on other sites

UPDATE: So, I decided to wait for the game to load in Italy, and it turns out it does load, but only after about 20 minutes. Colombia suffers from the same issue as well.

This is not ideal, of course, but if you have patience (which I'm sure you have lots, if you're still playing the game), you can get to Italy.

I also found out that this happens in Japan, too, although the loading times are about 5 minutes.

Yet another bug to crush, hopefully in the next update.

Edited by Gabrielmpf

Share this post


Link to post
Share on other sites

 

If on ps4 could try safe mode and rebuild database seems like that checks disc and defrags or something similar.

I was able to travel between Montana and Columbia with Landini REX left in Columbia haven't re-visited other maps cause of slow speed bug when travelling with vehicles till you save and reload! And I won't even go back to Columbia either till the next patch hopefully fixes this!

Share this post


Link to post
Share on other sites

Yep, I experienced that, too. And I'm on Xbox One. First time that happened. I insisted a couple of times after that and it loaded, only after another 20 minutes or so.

I have also experienced the long loading time in Colombia now, as well. Sent a ticket to support, but the help they give you leaves a lot to be desired. Hopefully the next update can fix this somehow.

Share this post


Link to post
Share on other sites

So, as of now, I can't load the game in Italy at all. The game crashes every time. Tried to travel to Italy from every map and the result is the same: crash!

Tried to start a new game and travel from one place to another. Italy starts doing this even from the start. At first, the game takes longer than usual to load, but it does after a couple of minutes. But, as you start purchasing new fields and add new equipment to the map, the game seems to not like this and the loading times take longer each time you travel there. It seems to build up, right until the moment where it can't load anymore and just crashes.

This has to be the most polarizing game I have ever played: on one hand, it has great gameplay and brilliant ideas with a variety of tasks; on the other hand, it's an absolute disaster in technical terms with bugs aplenty. Technically, it's The worse experience I've had in over 25 years of gaming. As a game, though, it's one of the most satisfying experiences I've had in over 25 years of gaming (only Elite Dangerous and FS 17 can get into the same club). All of this, with the same game. How is this possible?

My question to the developers: have you guys even played your game? Like, seriously, really play the game like a proper gamer, and see the myriad of problems the game has from the point of view of a gamer. 90% of all these bugs and game-lacking features (real time, high fuel consumption, etc...) could've been avoided had you played the game properly.

Such promise with a beautiful game, and yet such poor execution. What a waste of great ideas.

There's an update coming, but my expectations right now are very low. It will probably fix some problems, and cause a few others in the process.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0