Sign in to follow this  
Followers 0
Disinfo

Game crashing when loading my custom map

17 posts in this topic

Hi!

I have been working on a map for over 3 weeks now and so far everything had worked perfectly. 

Today I added some dynamic lights with lamps that turn on at night (not sure if they are the cause) and the game started crashing when loading my map. 

Tried validating and finding errors, but I'm not sure if I'm doing it right. 

Can anyone help with resolving the issue? For a moment I though it might be because of duplication of the lights (I copied the first one that I made to save time). 

Any help would be appreciated. 

Untitled.jpg

I also added some FX here and there, before it started crashing. (dust, hot air refraction, etc)  Could they be the reason? 

Share this post


Link to post
Share on other sites

try fixing the errors and see if the game doesn't crash.

if you can't fix them, remove meshes that give errors and see what happens (dlc_wl_ve_sedan_a_bonnet.msh, etc)(

also remove the encounter car (no sure what that is)

but remove any object that is connected to the error and see if the game still crashes.

that's the first step to see what's crashing the game.

 

duplicating dynamic lights should'nt crash the game, ive done that multiple times.

neither should fxes

 

if the game still crashes after removing the error giving objects, then that's a tougher thing to try and fix, but i's start with that.

Edited by doomguy

Share this post


Link to post
Share on other sites

Removing objects with errors, the game still crashes when loading my map.  Is there any way to find out what exactly is causing it to crash? Like a log file or something?

Share this post


Link to post
Share on other sites

i cant go through the log now

do you have a lot of stuff on your map? you can always try and migrate your old map to a new map

sometimes the tools bug and stay bugged

good luck!

Share this post


Link to post
Share on other sites

I am getting a MapStart [HomePoint/Spawnpoint]  error in the quest editor. Could that be causing the crash?  My original spawnpoint is still there though. What would be the right way to add one of those? 

Screenshot:

https://drive.google.com/file/d/0B8zaKWbeF3KLRldBSzlka09xOVE/view?usp=sharing

Update: fixed the spawnpoints, by adding two Spawn Points and giving them names as in the quest editor. 

Map still crashing the game while being loaded.

Also, is it possible to "migrate" to a new map and keep my terrain? I did some quite complex terrain editing with hills and wouldn't want to lose that. 

Edited by Disinfo

Share this post


Link to post
Share on other sites

don't know about the terrain migration

but how many spawn do you have in total?

you understand the spawns you have in the quest (screenshot) are debug spawns, and if you have no other spawns and play the map without using invoke, that might crash the game, idk

comment out the quests, and place only one spawnpoint on the map and play the map (without using invoke - thats the other option when you click the play button's drop down arrow)

 

also, there's a few errors in your log

ERROR [FX] Cannot read definition of btzh_light_end_light.fx

search for "error" in the log and see. remove or fix that which gives errors and see if it helps

Edited by doomguy

Share this post


Link to post
Share on other sites

like i said, remove the quests to see if they are crashing the game. (copy them onto a empty text file, so you can copy it back)

2. remove the FX's that are giving the errors.

3. remove the spawns.

4. add a spawnpoint with it's default setting (dont mess with the settigns of the spawn when placing it on the map).

5. click play.

see if it crashes.

 

sorry i can't test you map, i'm testing and fixing mine at the moment.

Share this post


Link to post
Share on other sites

You could test your whole map ´s objects

in another project to see if the crash is caused by objects or by a corrupted

mymap.map or mymap.exp files.

If the map or exp file is corrupted,

you should not be able to load it in the tools.

 

So check by elimination process.

Create a group with all the objects on the

map and test this group in a new clean map:

http://steamcommunity.com/workshop/discussions/18446744073709551615/1457328927827679897/?appid=239140

Share this post


Link to post
Share on other sites

I am trying to do that now, it's going to take a while. 

Posted all objects to a new map once, it crashed in the same way. I suspect it might be caused by a grass mesh.

Hopefully I will get it all fixed and post a video of some of my complete work soon. 

Share this post


Link to post
Share on other sites

Also make sure you don ´t include 

any movie actor that is linked with a movie in any object group.

I mean if you export a group in another

project, exclude movie actors , the problem is not the movie actor class,

but the link between the movie and actor

will make your group to crash the map

when you put it on a map with the assets

tool or when you test ingame.

If you have movies, you can export them through the movie tool .

Share this post


Link to post
Share on other sites

there's an option in the top menu: Validate & Build, Map Loading Errors...you should look into that and see if it tells you anything

edit: or maybe not, it'll probably just give you errors that you see if you where to test the map

Edited by doomguy

Share this post


Link to post
Share on other sites

That was the first thing I did. 

Just manage to locate the problem: what I did was to delete large selections with models on the map to find out which area is causing the crash. 

It was this invisible object. 

Thanks for the help! o26SKF7.jpg

Share this post


Link to post
Share on other sites

Glad you fixed the map.

Yeah, the animal class is inherited from

older engines iterations and no longer

supported.

Some old classes are not making any harm to this engine and they will not affect

anything but some classes could make

problems.

Devs can ´t remove them because

they are tied too deep into the java code

of classes.

So unusual classes that are not used in

Dying Light should be avoided.

But we can use some of them like

collisionrecievier .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0